+91 90691 39140 | +1 253 214 3115 | info@hub4tech.com | hub4tech

OSPF Area0 and DR-BDR


Open Shortest Path First (OSPF) It is an open standard routing protocol that’s been implemented by a wide variety of network vendors. By using the Dijkstra algorithm. A shortest path tree is constructed, andthen the routing table is populated with the resulting best paths.

OSPF provides the following features:

  • Consists of areas and autonomous systems
  • Minimizes routing update traffic
  • Allows scalability
  • Supports VLSM/CIDR
  • Has unlimited hop count
  • Allows multi-vendor deployment (open standard)
Designated router

A Designated Router (DR)is elected whenever OSPF routers are connected to the same multi-access network

Backup designated router

A Backup Designated Router (BDR)is a hot standby for the DR on multi-access links.The BDR receives all routing updates from OSPF adjacent routers but doesn’t flood LSA updates.

OSPF areas

An OSPF area is a grouping of contiguous networks and routers. All routers in the same area share a common Area ID. Because a router can be a member of more than one area at a time, the Area ID is associated with specific interfaces on the router. This would allow some interfaces to belong to area 1 while the remaining interfaces can belong to area 0. All of the routers within the same area have the same topology table.

Broadcast (multi-access)

Broadcast (multi-access) networks such as Ethernet allow multiple devices to connect to (or access) the same network as well as provide a broadcast ability in which a single packet is delivered to all nodes on the network. In OSPF, a DR and a BDR must be elected for each broadcast multi-access network.

Non-broadcast multi-access

Non-broadcast multi-access (NBMA) networks are types such as Frame Relay, X.25, and Asynchronous Transfer Mode (ATM). These networks allow for multi-access but have no broadcast ability like Ethernet. So, NBMA networks require special OSPF configuration to function properly and neighbor relationships must be defined.DR and BDR are elected on broadcast and non-broadcast multi-access networks.

Point-to-point

Point-to-point refers to a type of network topology consisting of a direct connection between two routers that provides a single communication path. The point-to-point connection can be physical, as in a serial cable directly connecting two routers, or it can be logical, as in two routers that are thousands of miles apart yet connected by a circuit in a FrameRelay network. In either case, this type of configuration eliminates the need for DRs or BDRs — but neighbors are discovered automatically.

Point-to-multipoint

Point-to-multipoint refers to a type of network topology consisting of a series of connections between a single interface on one router and multiple destination routers.All of the interfaces on all of the routers sharing the point-to-multipoint connection belong to the same network. As with point-to-point, no DRs or BDRs are needed.All of these terms play an important part in understanding the operation of OSPF.

SPF Tree Calculation

Within an area, each router calculates the best/shortest path to every network in that same area. This calculation is based upon the information collected in the topology database and an algorithm.

OSPF uses a metric referred to as cost. A cost is associated with every outgoing interface included in an SPF tree. The cost of the entire path is the sum of the costs of the outgoing inter-faces along the path.

DR and BDR Elections

On a broadcast or non-broadcast multi-access network, the router with the highest OSPF priority on a segment will become the DR for that segment. This priority is shown with the show ip ospf interface command, which is set to 1 by default. If all routers have the default priority set,the router with the highest Router ID (RID).

If you set a router’s interface to a priority value of zero, that router won’t participate in the DR or BDR election on that interface. The state of the interface with priority zero will then be DR OTHER.



R1#show run | sec router ospf

router ospf 1
 network 1.1.1.1 0.0.0.0 area 0
 network 10.1.1.0 0.0.0.255 area 0


R2#show run | sec router ospf

router ospf 1
 network 2.2.2.2 0.0.0.0 area 0
 network 10.1.1.0 0.0.0.255 area 0


R3#show run | sec router ospf

router ospf 1
 network 3.3.3.3 0.0.0.0 area 0
 network 10.1.1.0 0.0.0.255 area 0








Is it Helpful?
Copyright ©2015 Hub4Tech.com, All Rights Reserved. Hub4Tech™ is registered trademark of Hub4tech Portal Services Pvt. Ltd.
All trademarks and logos appearing on this website are the property of their respective owners.
FOLLOW US